Chiller failure

General brewing equipment discussion

Moderator: rsc3da

Chiller failure

Postby blksabbath » Sun Nov 04, 2018 10:11 am

I finally was able to brew for the first time in almost a year...10 gallons of American pale ale. Everything went great until chilling. Turned the chill water on to my immersion chiller and couldn’t figure out why just a trickle was coming out of the waste end, then my keggle overflowed. One of the coils near the bottom burst mixing hose water into my now chilling beer. Fuck! No salvage situation. The whole batch went down the drain.

Lesson learned...run some water through your chiller if it’s been sitting for a long time. I’m thinking it was probably weakened sitting in my unheated shed over winter with a little residual water inside.

Dan G


Sent from my iPhone using Tapatalk
Dude! Lets hang out!
User avatar
blksabbath
 
Posts: 872
Joined: Fri Jan 12, 2007 10:04 am
Location: Shrewsbury

Re: Chiller failure

Postby robininski » Thu Nov 08, 2018 12:24 pm

The bottom third of the wort would have been fine, if the tap water came from whole house filter of any sort and the next third, probably ok also, just a lighter version.
I would have a least pitched yeast into the first running, regardless. What's to loose? (a pack of yeast?).
Rob
User avatar
robininski
 
Posts: 36
Joined: Tue Apr 24, 2012 11:27 am
Location: Godfrey, IL

Re: Chiller failure

Postby blksabbath » Fri Nov 09, 2018 4:22 pm

This was straight hose water, unfiltered. I don't see how the bottom or any of it for that matter would be untainted by chill water since the volume went from about 11gal to 15 from the bottom up.
Dude! Lets hang out!
User avatar
blksabbath
 
Posts: 872
Joined: Fri Jan 12, 2007 10:04 am
Location: Shrewsbury

Re: Chiller failure

Postby StLBeer » Sat Nov 10, 2018 12:26 pm

Dude, that totally sucks. Sorry to hear about your loss.
Serving - Dark Medicine, JD Bigfoot Barleywine Clone, JD RIS (jealous?), American Wheat Ale, Nut Brown Ale, & Blondes...
Carbonating -
Primary - Big Ape AIPA
On Deck -
In the hole -
User avatar
StLBeer
 
Posts: 1324
Joined: Mon Apr 09, 2007 1:08 am
Location: Fenton


Return to Equipment Discussion

Who is online

Users browsing this forum: No registered users and 12 guests

cron