Yeast Issue

General brewing ingredients discussion

Moderator: rsc3da

Yeast Issue

Postby TCochran » Fri Nov 01, 2013 7:21 pm

On Wednesday I bought Wyeast 1056 from St. Louis Wine & Beer. Today I brewed a Rye IPA planning on using this yeast for the batch. I went to pull the yeast out of the fridge and the bubble in the smack pack had already been broken. Did I buy it that way? I can't say. I let the pack out to swell. It was a cool day around 65 according to my thermostat.
The yeast pack never really swelled like it should have. It was out for sufficient amount of time. In the past the package always swelled very tight. This package never did. As I went through my brewing process I added some yeast nutrient as a precaution.
I cooled my wort to the appropriate temperature. I pitched the yeast as usual. I usually don't do this but for some reason I tasted what I could of the yeast after I pitched it. It tasted rather tart, making me think the it was infected. I guess time will tell, but I am not optimistic about the outcome.
So looking for some guidance to see if anyone has any experience like this?
User avatar
TCochran
 
Posts: 623
Joined: Thu Sep 25, 2008 5:15 pm
Location: Crestwood

Re: Yeast Issue

Postby Mike C-Z » Fri Nov 01, 2013 11:20 pm

Was there an off aroma to the yeast? I would probably try to add healthy yeast and hope it outperforms any possible funk from the yeast pack. I have plenty from Kirkwood Station if you want to go that route. Maybe bring a container to Teach a Frind to Homebrew day and I can give you some there, American ale yeast.
Teaching that does not promote learning makes as much sense as brewing that does not promote drinking.
Mike C-Z
 
Posts: 380
Joined: Sat Sep 13, 2008 12:38 am
Location: Maplewood


Return to Ingredients Discussion

Who is online

Users browsing this forum: No registered users and 5 guests